Com extreure les últimes N paraules

Per extreure les últimes N paraules de la cadena de text, heu de trobar la ubicació relativa de l'últim espai enèsimo, substituir-lo per un caràcter especial per distingir-lo amb altres espais i, a continuació, utilitzar Funció correcta .

Fórmula:

Copieu la fórmula i substituïu 'A1' pel nom de la cel·la que conté el text que voleu extreure i canvieu N pel número que necessiteu.

=SI((LEN(A1)-LEN(SUBSTITUT(A1,' ','')))

Exemple:

Per extreure l'últim cinc paraules de la cadena de text ' Com extreure les últimes N paraules '.

El resultat retorna les últimes cinc paraules ' Extreu les últimes N paraules '.

Explicacions:

Pas 1: Per comptar el nombre d'espais

Fórmula =LEN(A1)-LEN(SUBSTITUT(A1,' ',''))
Resultat 6

Pas 2: Substituïu el cinquè espai de l'últim per qualsevol caràcter especial (p. ex., /)

Fórmula =SUBSTITUT(A1,' ','/',(LEN(A1)-LEN(SUBSTITUT(A1,' ',''))-5+1))
Resultat Com extreure/extreure les últimes N paraules

Pas 3: Trobeu la ubicació del personatge especial

Fórmula =TROBAR('/',SUBSTITUT(A1,' ','/',(LEN(A1)-LEN(SUBSTITUT(A1,' ',''))-5+1)))
Resultat 7

Pas 4: El nombre de lletres després del caràcter especial

Fórmula =LEN(A1)-TROBAR('/',SUBSTITUT(A1,' ','/',(LEN(A1)-LEN(SUBSTITUT(A1,' ',''))-5+1)))
Resultat 24

Pas 5: Recolliu les lletres després del caràcter especial

Fórmula =DRETA(A1,LEN(A1)-TROBAR('/',SUBSTITUT(A1,' ','/',(LEN(A1)-LEN(SUBSTITUIR(A1,'',''))-5+1 ))))
Resultat Extreu les últimes N paraules

Tanmateix, quan la cadena de text té menys de 5 paraules, la fórmula '=FIND('/',SUBSTITUTE(A1,' ','/', (LEN(A1) – LEN(SUBSTITUTE(A1,' ','') )-5+1)))' retorna #VALOR! error. Per evitar-ho, cal combinar amb el Funció IFERROR .

=SI((LEN(A1)-LEN(SUBSTITUT(A1,' ','')))<5, A1, DRET(A1, LEN(A1)- TROBA ('/', SUBSTITUT(A1,' ', '/', (LEN(A1)- LEN(SUBSTITUT(A1,' ',''))-5+1))))